QuickBooks Integration Service Disruption

Incident Report for Flourish Software

Resolved

The QuickBooks integration is now operating normally.
Posted Jun 20, 2026 - 10:04 EDT

Investigating

We are investigating an issue with the QuickBooks integration.
Posted Jun 20, 2026 - 10:01 EDT
This incident affected: Quickbooks API.