Flourish Web Service Disruption

Incident Report for Flourish Software

Resolved

The Flourish Web service has been restored and is operating normally.
Posted Jun 17, 2026 - 09:40 EDT

Investigating

We are investigating reports of Flourish Web service issues. Error details: HTTP 503... This issue has persisted for 10 consecutive checks. Status Code: 503 URL: https://app.flourishsoftware.com/bff/auth/login
Posted Jun 17, 2026 - 09:38 EDT
This incident affected: Flourish Web.