LeafLink Inventory Sync Service Disruption

Incident Report for Flourish Software

Resolved

LeafLink inventory sync is now functioning normally. Detected 8983 successful syncs in the last monitoring window.
Posted Mar 08, 2026 - 05:50 EDT

Investigating

We are investigating an issue with LeafLink inventory sync. No successful syncs detected in the last monitoring window. (Minimum 1 required)
Posted Mar 08, 2026 - 05:49 EDT
This incident affected: Leaflink.