Flourish Service Disruption

Incident Report for Flourish Software

Resolved

The service has been fully restored.
Posted Jan 08, 2026 - 10:26 EST

Investigating

We are investigating reports of service disruption.
Posted Jan 08, 2026 - 10:25 EST
This incident affected: Flourish Web.